Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Appear over element which has a "fixed" CSS position. #160

Open
CassySpencer opened this issue Mar 14, 2017 · 5 comments
Open

Appear over element which has a "fixed" CSS position. #160

CassySpencer opened this issue Mar 14, 2017 · 5 comments
Labels

Comments

@CassySpencer
Copy link

CassySpencer commented Mar 14, 2017

Please can someone help me?

I'm seeing a strange bug where the tool tip hides beneath an element that has a fixed position.

screen shot

You can see in my screenshot that my tooltip has a z-index of 1000000 and next to it is a golden did that has a z-index of 10. The golden DIV also as a fixed position. However whenever the tooltip appears, it always hides beneath the golden DIV. I have to keep the position fixed as the gold DIV is a toolbar and must remain floating above other elements.

Please can someone help as I don't know too much about CSS?
Thank you.

@chinchang
Copy link
Owner

chinchang commented Mar 14, 2017

@CassySpencer is this page public where I can see the issue? z-indexes are not that easily comparable between any 2 elements on the page, so I need to see the actual page to be able to suggest something.

@CassySpencer
Copy link
Author

CassySpencer commented Mar 14, 2017

Thank you. The page is not publicly accessible. Can you trying adding a "fixed" positioned next to something that shows your tooltip and see who that affects the tooltip?

@CassySpencer
Copy link
Author

CassySpencer commented Mar 16, 2017

@chinchang Have you had any luck with this?

@chinchang
Copy link
Owner

chinchang commented Mar 16, 2017

@CassySpencer As mentioned, the issue isn't something because of just fixed positioned element. For example, see the demo here -> http://codepen.io/chinchang/pen/dvZpjd
The tooltip shows fine there. So probably your content (containing tooltip) is itself in some element having z-index lower than 10.
You could try replicating a minimum structure of your page on codepen and share here for debugging.

@chinchang chinchang added the bug label Mar 16, 2017
@CassySpencer
Copy link
Author

CassySpencer commented Mar 16, 2017

@chinchang Thank you So much :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

2 participants